update apt-get commands for debian/ubuntu

Discuss issues related to installing or building
Post Reply
michkrom
Posts: 4
Joined: Sat Apr 17 2021 6:28 pm

update apt-get commands for debian/ubuntu

Post by michkrom »

Hi,

Could the commands listed in docs be updated to a directly copy-pastable, like in this below (notice the sudo and -y and missing ninja-build)?

sudo apt-get install -y libfreetype6-dev libfontconfig1-dev libglib2.0-dev libgstreamer1.0-dev \
libgstreamer-plugins-base1.0-dev libice-dev libaudio-dev libgl1-mesa-dev libc6-dev \
libsm-dev libxcursor-dev libxext-dev libxfixes-dev libxi-dev libxinerama-dev \
libxrandr-dev libxrender-dev libxkbcommon-dev libxkbcommon-x11-dev libx11-dev

sudo apt-get install -y libxcb1-dev libx11-xcb-dev libxcb-glx0-dev libxcb-icccm4-dev libxcb-image0-dev libxcb-keysyms1-dev \
libxcb-render0-dev libxcb-render-util0-dev libxcb-randr0-dev libxcb-shape0-dev \
libxcb-shm0-dev libxcb-sync-dev libxcb-xfixes0-dev libxcb-xinerama0-dev libxcb-xkb-dev

sudo apt-get install -y ninja-build

Regards,
Michal

barbara
Posts: 268
Joined: Sat Apr 04 2015 2:32 am

Re: update apt-get commands for debian/ubuntu

Post by barbara »

could the commands listed in docs be updated to a directly copy-pastable
We are bit confused since we do have a "package install command" for all Unix platforms underneath each table. You can copy and paste to a script on your system.

https://www.copperspice.com/docs/cs_overview/requirements-unix.html#ubuntu18-cs-dev
( scroll down below the table )

In terms of the -y, this would force the package to be installed and overwrite anything you currently have on your system. This is not a good practice since a system admin should review before over writing or upgrading.

Our command should not assume your level of permissions. Sometimes using sudo is the right answer and other times it is not. This is something users should only add if and when it is required.
sudo apt-get install -y ninja-build
Our package install commands do not include anything for installing your tool chain. Not everyone uses ninja so installing this for someone who is using Make would be unnecessary. Developers will need to install applications like clang, gcc, cmake, ninja, make, git, etc.

Post Reply