copperspice 1.6.2 build issue with POSIX threads library

Discuss issues related to installing or building
Post Reply
marlowa
Posts: 112
Joined: Sun Oct 25 2015 10:52 am

copperspice 1.6.2 build issue with POSIX threads library

Post by marlowa »

Hello everyone,

I am struggling to build copperspice 1.6.2 on KDE Neon using gcc7. I know KDE Neon is not a supported platform. However, I think the problem I am seeing is quite common to projects that use cmake that also use POSIX threads. The problem is how the library is specified to the linker. Copperspice looks to be using -lpthreads. In my environment -pthread is required. I realise that this whole issue is very platform-dependent so I don't know what to say. I note that in the configuration stage it says:

-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found

and yet somehow it still winds up using -lpthreads. Can someone help/advise please?

Post Reply