ubuntu 20 incomplete dependency list

Discuss issues related to installing or building
Post Reply
seasoned_geek
Posts: 18
Joined: Thu Jun 11 2020 12:18 pm

ubuntu 20 incomplete dependency list

Post by seasoned_geek »

Hello,

Long time Qt developer and author kicking the tires on CopperSpice. Started some blog posts about the beginnings of the journey and why.
https://www.logikalsolutions.com/wordpress/uncategorized/copperspice-and-diamond/

Haven't finished writing the third post yet because having issue.

I started with a minimal install. The only other things installed were BOINC, NVidia drivers, Gnu Emacs, and JED. I used the package install commands from here:

https://www.copperspice.com/docs/cs_overview/requirements-unix.html#ubuntu20-cs1-6

I then installed Postgres and created some PostgreSQL databases.

http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/libpq-1.png
http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/libpq-2.png
http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/postgres-1.png
http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/postgres-3.png
http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/postgres-10.png
http://www.logikalsolutions.com/wordpress/wp-content/uploads/2020/06/postgres-13-2.png

Yes, no data for 2020 yet, but from 1996 or so forward, all there. I even rebooted after installing all of that stuff and before creating the databases. I planned on the first real test being a port of

https://sourceforge.net/projects/xpnsqt/

Been using that project for years. That and a lottery tracker application are my go-to tire kickers.

The required package list appears to be a bit short.

Code: Select all

-- The following packages have not been found:

 * OpenSSL (required version >= 1.0), Support for SSL and TLS, <https://openssl.org>
   Required for HTTPS support
 * Cups, CUPS is the standards-based open source printing system, <https://www.cups.org>
   Required for printing support
 * ALSA, Advanced Linux Sound Architecture, <http://www.alsa-project.org>
   Required for ALSA audio support
 * PulseAudio, Sound processing daemon for Unix, <http://www.pulseaudio.org>
   Required for pulseaudio support
 * PostgreSQL, Popular open source database, <http://www.postgresql.org>
   Required for PostgreSQL database support
 * MySQL, Popular open source database, <http://www.mysql.com>
   Required for MySQL database support
 * LibXml2, XML C parser and toolkit developed for the Gnome project, <http://www.xmlsoft.org/>
   Required for XML support in WebKit


CopperSpice configured to run on:  Linux 64 bit, Release Mode
CopperSpice will be built in:      /home/roland/Projects/cs_build
CopperSpice will be installed in:  /usr/lib/cs_lib


-- Configuring done
-- Generating done
-- Build files have been written to: /home/roland/Projects/cs_build
roland@roland-amd-desktop:~/Projects/cs_build$


I can print just fine from the default text editor on this system. I'm using FireFox to post this and see a little lock meaning I'm secure. I see ALSA and PulseAudio were listed in the table and simply left off the apt-get install commands so I should be able to fix that.

Can someone please tell me what the Ninja process is looking for when it comes to SSL, CUPS, and PostgreSQL? I honestly thought I had everything I would need for PostgreSQL.

Like most of the OpenSource community, I ceased caring about MySQL once Oracle bought InnoDB.

Thanks

Btw, who set the ludicrous "images can only be 1 pixels high" rule on here? Screenshots really help all things.

seasoned_geek
Posts: 18
Joined: Thu Jun 11 2020 12:18 pm

Re: ubuntu 20 incomplete dependency list

Post by seasoned_geek »

Installing

Code: Select all

sudo apt-get install libpulse-dev libasound2-dev libssl-dev libcups2-dev \
                libxml++2.6-dev
Got me this far.

Code: Select all

-- The following packages have not been found:

 * PostgreSQL, Popular open source database, <http://www.postgresql.org>
   Required for PostgreSQL database support
 * MySQL, Popular open source database, <http://www.mysql.com>
   Required for MySQL database support


CopperSpice configured to run on:  Linux 64 bit, Release Mode
CopperSpice will be built in:      /home/roland/Projects/cs_build
CopperSpice will be installed in:  /usr/lib/cs_lib


-- Configuring done
-- Generating done
-- Build files have been written to: /home/roland/Projects/cs_build
roland@roland-amd-desktop:~/Projects/cs_build$ 
I'm really stumped as to what configuration could be looking for when it comes to PostgreSQL.

https://www.tutorialspoint.com/postgresql/postgresql_c_cpp.htm

I've got the official packages installed.

ansel
Posts: 79
Joined: Fri Apr 10 2015 8:23 am

Re: ubuntu 20 incomplete dependency list

Post by ansel »

seasoned_geek wrote:
Thu Jun 11 2020 12:59 pm
Btw, who set the ludicrous "images can only be 1 pixels high" rule on here? Screenshots really help all things.
Sorry about that, we have had some issues of people posting way too many images. Screenshots add too much noise to the discussion thread in our experience. Posting links to an image gallery in the forum is absolutely fine but in-line images were becoming a problem.
Ansel Sermersheim
CopperSpice Cofounder

ansel
Posts: 79
Joined: Fri Apr 10 2015 8:23 am

Re: ubuntu 20 incomplete dependency list

Post by ansel »

The team is working on a more detailed response for all of your dependency questions.
Ansel Sermersheim
CopperSpice Cofounder

barbara
Posts: 172
Joined: Sat Apr 04 2015 2:32 am

Re: ubuntu 20 incomplete dependency list

Post by barbara »

Can someone please tell me what the Ninja process is looking for when it comes to SSL, CUPS, and PostgreSQL? I honestly thought I had everything I would need for PostgreSQL.
Thought I would start from the beginning, if that is ok. The following page contains the steps for configure, compile. After that, you do need to install. It looks like you ran the configure step but I am not sure about the other ones.

https://www.copperspice.com/docs/cs_overview/build-overview.html

It looks like you found the required packages for ssl and cups. For PostgreSQL on Ubuntu 20.04 you will need to install libpq-dev.

We looked briefly at your blog and this was a blast for us. Really wonderful to have people reviewing our work and we hope you continue. Let us know your next set of questions . . .

Barbara

seasoned_geek
Posts: 18
Joined: Thu Jun 11 2020 12:18 pm

Re: ubuntu 20 incomplete dependency list

Post by seasoned_geek »

Actually that wasn't the answer.

The final success can be found in this post.
https://www.logikalsolutions.com/wordpress/information-technology/copperspice-experiments-pt-4/

Post Reply