Which Package?

Discuss issues related to installing or building
Post Reply
Clas
Posts: 10
Joined: Tue Nov 03 2015 7:39 pm

Which Package?

Post by Clas »

Hi,

I tried to build CopperSpice on Linux Mint 17.2. After cloning
from github I called

./autogen.sh
./configure

then I got following output:

checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking for net/if.h... yes
checking for library containing clock_gettime... none required
checking for FONTCONFIG... yes
checking for FREETYPE... yes
checking for GLIB... yes
checking for GSTREAMER... yes
checking for GSTREAMER_AUDIO... yes
checking for GTK... yes
checking for library containing IceOpenConnection... -lICE
checking for library containing AuOpenServer... no
checking for library containing glClear... -lGL
checking for library containing pthread_create... -lpthread
checking for library containing SmcOpenConnection... -lSM
checking for library containing XcursorImageCreate... -lXcursor
checking for library containing XShmCreateImage... -lXext
checking for library containing XFixesQueryVersion... -lXfixes
checking for library containing XGetExtensionVersion... -lXi
checking for library containing XineramaQueryExtension... -lXinerama
checking for library containing XRRSetScreenConfigAndRate... -lXrandr
checking for library containing XRenderCreateCursor... -lXrender
checking for library containing XCreateWindow... -lX11
------------------------------------------------------------
The following libraries are missing and must be installed to build CopperSpice
Refer to the CS documentation for package names or consult your platform package manager
Audio
------------------------------------------------------------

CopperSpice configuration aborted

I search in CS documentation for sound or audio packages needed by CS. But
I dont found something. Can somebody tell me which audio package I need
to install first or how I can deactivate or disable this package for configuration.

Thanks

clas

Clas
Posts: 10
Joined: Tue Nov 03 2015 7:39 pm

Re: Which Package?

Post by Clas »

What does mean:

checking for library containing AuOpenServer... no

Which package exactly:

alsa-dev package
esound-dev package

Which audio dev package is necessary?

Which apt-get install XXXXXXXX I need to type in?

I dont know.

Thanks,

clas

smil3y
Posts: 8
Joined: Thu Jul 30 2015 5:01 pm

Re: Which Package?

Post by smil3y »

Clas wrote:What does mean:

checking for library containing AuOpenServer... no

Which package exactly:

alsa-dev package
esound-dev package

Which audio dev package is necessary?

Which apt-get install XXXXXXXX I need to type in?

I dont know.

Thanks,

clas
The build requirements are listed at http://www.copperspice.com/docs/cs_over ... s-x11.html.

Cheers!

ansel
Posts: 71
Joined: Fri Apr 10 2015 8:23 am

Re: Which Package?

Post by ansel »

What does mean:

checking for library containing AuOpenServer... no

Which package exactly:
Hi Clas,

If you check our build requirements page at http://www.copperspice.com/docs/cs_over ... s-x11.html you will see that the 'libaudio' library is provided by the 'libaudio-dev' package on both Debian and Ubuntu, or the 'nas-devel' package on Fedora.

Ansel Sermersheim

Clas
Posts: 10
Joined: Tue Nov 03 2015 7:39 pm

Re: Which Package?

Post by Clas »

Hi Ansel,

Im sorry. I oversaw it because I was to quickly.
Sorry. Now, I stop to spam this forum with my
stupid questions.

Thanks,

Clas

Clas
Posts: 10
Joined: Tue Nov 03 2015 7:39 pm

Re: Which Package?

Post by Clas »

Hi Ansel,

Great. I could build it now on my Linux Mint System.

Thanks for support.

Clas

Post Reply